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Symbo ls and Conventions  

This manual uses certain symbols and conventions, the meaning s of which are 

explained below: 

 

This symbol is used to mark useful tips that can make your wor k 

easier. 

 

 

This symbol indicates additional informative text. 

 

 

This symbol indicates an important tip or procedure that may have far -

reaching effects. Please consider carefully the consequences of any 

settings or changes you make here. 

 

 

This symbol indicates there is additional information on this topic in 

the online help. 

 

 This symbol shows cross references to internal or external content.  

¶ Keys or key combinations are displayed in square brackets, e .g. [Space]. 

¶ References to program commands and dialog boxes are printed in bold  type, 

e.g. Select the command Klaj . 

¶ Options and buttons that can be selected in dialog boxes  are printed in bold 

type, e.g. user defined . 

¶ Text, screen displays and file names to be entered by the user  are displayed 

in the font Courier New . This input is  ̄unless otherwise mentioned - case 

sensitive. 

¶ In this documentation, product names are abbreviated as follows:  

Product name  Abbreviation  

HOB WebSecureProxy WSP 

HOB WebSecureProxy Universal Client WSP UC 

HOB Enterprise Access EA 
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Purpose of This Manual  

This manual is designed to provide system administrators with detail ed 

information about HOB RD VPN to help them decide where and when this 

product can be most effective ly deployed in their enterprise network.   

This documentation contains descriptions of numerous possible scenarios, and 

explains the required conditions. The procedures for configuring the individual 

software components are documented in detail with step -by-step instructions.  

 

 



HOB RD VPN _________________________________________________________________ Introduction  

Security Solutions by HOB  5 

Table of Contents  

Symbols and Conventions  ......................................................................................................................... 3 

Purpose of This Manual ............................................................................................................................. 4 

Table of Contents  5 

1. Introduction  9 

1.1. Advantages of HOB RD VPN .................................................................................................... 9 

1.2. HOB RD VPN Components ....................................................................................................... 9 

2. Installation  13 

2.1. System Requirements ............................................................................................................. 13 

2.2. How to Install HOB RD VPN .................................................................................................... 15 

2.3. Changing from Local Configuration to Remote Configuration  ................................................ 15 

2.4. Changing the IP Address/Port  ................................................................................................ 21 

2.5. Customizing HOB RD VPN Web Pages .................................................................................. 24 

2.6. Uninstallation ........................................................................................................................... 26 

2.7. Saving Installation and Configuration Data ............................................................................. 26 

3. User Management with HOB Enterprise Access  27 

3.1. The HOB EA Concept ............................................................................................................. 27 

3.2. The HOB EA Administration Configuration Program ............................................................... 28 

3.3. HOB RD VPN User Settings .................................................................................................... 31 

3.4. HOB EA Server ........................................................................................................................ 33 

3.5. LDAP Considerations .............................................................................................................. 34 

3.6. Startup Options Manager  ........................................................................................................ 34 

3.7. Authentication ......................................................................................................................... 35 

3.8. Single Sign-On ........................................................................................................................ 36 

3.9. Configuration Program for HOB WSP ..................................................................................... 36 

3.10. Remote Configuration of the HOB WSP ................................................................................. 38 

3.11. Saving the HOB RD VPN Configuration in LDAP .................................................................... 41 

4. HOB PPP Tunnel 51 

4.1. Installation and Configuration  ................................................................................................. 52 

4.2. Using the HOB PPP Tunnel ..................................................................................................... 59 

5. HOB Web File Access  61 

5.1. Web File Access - Configuration ............................................................................................. 61 

5.2. Working with Web File Access ................................................................................................ 63 

6. Access to Enterprise -Internal Web Servers ® HOB Web Server Gate  65 

6.1. HOB RD VPN Web Server Gate .............................................................................................. 65 

6.2. Using the HOB Web Server Gate ............................................................................................ 66 

6.3. Intranet Hyperlinks on HTML Pages of Internal Web Servers ................................................. 67 

6.4. Auto Logon to Intranet Servers  ............................................................................................... 67 



Introduction  _______________________________________________________ HOB RD VPN 

6 Security Solutions by HOB  

7. Anti Split Tun neling 69 

7.1. Configure Anti Split Tunneling ................................................................................................ 69 

8. Application Scenarios  71 

8.1. Scenario: Default Configuration .............................................................................................. 71 

8.2. Configurations for Alternate Scenarios  ................................................................................... 76 

9. HOB RD VPN Desktop -on-Demand 89 

9.1. Remote Access to Windows Operating Systems  ................................................................... 89 

9.2. Requirements ......................................................................................................................... 90 

9.3. Configuration of the Desktop -on-Demand Data ..................................................................... 90 

9.4. Wake-on-LAN Relay ............................................................................................................... 95 

10. HOB VDI Business 97 

10.1. Remote Access to a Single-User Operating System .............................................................. 97 

10.2. Requirements ......................................................................................................................... 98 

10.3. HOB VDI Agent ....................................................................................................................... 98 

11. Server Data Hook  99 

12. HOB RD VPN Linux/Unix Tools  101 

12.1. Changing the Configuration While in Operation  ................................................................... 101 

12.2. Port Listener for Unix ............................................................................................................ 103 

13. Security with SSL and TLS  105 

13.1. Encryption with SSL and TLS ............................................................................................... 105 

13.2. SSL Security in HOB RD VPN ............................................................................................... 105 

13.3. Create Server Keystore Files ................................................................................................ 106 

13.4. Create Client Keystore Files ................................................................................................. 108 

13.5. Selecting an SSL Provider .................................................................................................... 113 

14. Security Checks for HOB RD VPN  115 

14.1. Server ................................................................................................................................... 115 

14.2. Firewall .................................................................................................................................. 116 

14.3. Ports ..................................................................................................................................... 116 

14.4. Logging ................................................................................................................................. 117 

15. Trouble-Shooting  119 

15.1. Event Log (Windows OS Tool) .............................................................................................. 119 

15.2. Windows Dump .................................................................................................................... 119 

15.3. Console Messages ............................................................................................................... 120 

16. Information and Support  121 

17. Appendix 1 - HOB WSP Universal Client and Citrix Neighborhood  123 

17.1. Overview ............................................................................................................................... 123 

17.2. Client Configuration .............................................................................................................. 124 



HOB RD VPN _________________________________________________________________ Introduction  

Security Solutions by HOB  7 

17.3. Configure HOB WSP UC in HOB RD VPN ............................................................................ 125 

17.4. Configure HOB WebSecureProxy ......................................................................................... 126 

17.5. Establish the Connection ...................................................................................................... 127 

18. Appendix 2 - HOB WSP XML Configuration  129 

18.1. <sslgate-configuration> Tag ................................................................................................. 129 

18.2. <general> Tag ....................................................................................................................... 129 

18.3. Connection ............................................................................................................................ 134 

18.4. Blade Control  ........................................................................................................................ 145 

18.5. User Group ............................................................................................................................ 146 

18.6. RADIUS ................................................................................................................................. 147 

18.7. OCSP URL ............................................................................................................................ 148 

18.8. Client Side SSL ..................................................................................................................... 149 

18.9. Target Filter ........................................................................................................................... 149 

19. Index 151 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Introduction  _______________________________________________________ HOB RD VPN 

8 Security Solutions by HOB  

 



HOB RD VPN _________________________________________________________________ Introduction  

Security Solutions by HOB  9 

1. Introduction  

1.1. Advantages of HO B RD VPN 

With HOB RD VPN (Remote Desktop Virtual Private Network), you have a 

performant solution for secure remote access to the applications and data in 

your enterprise network. The user has the advantage of not having to install any 

software on a client. Any Internet connection point can be used to achieve this 

access. The user sees the Windows desktop of the rem ote system on their client 

computer , and can work with this as if it were locally installed on the PC.  

1.1.1.  HOB RD VPN ® A Versatile and Performant Solution  

HOB RD VPN provides numerous and varied solution scenarios for secure 

remote access to the Windows environments most often found in corporate 

networks: 

¶ HOB WTS Computing with the Java client HOBLink JWT for secure remote 

access to Micr osoft Window s Terminal Servers 

¶ HOB VDI Business for secure remote access to Windows operating systems  

running as virtual machines in computer centers  

¶ HOB Desktop on Demand for secure remote access to workstations running 

Windows 

¶ HOB Terminal Emulations with HOBLink J-Term for secure remote access to 

host systems 

 

1.2. HOB RD VPN Components  

The scope of delivery of HOB RD VPN consists of several components, 

described below.  

1.2.1.  HOB WebSecureProx y 

HOB WebSecureProxy (WSP) is the server component and is the central 

collection point for queries coming over the Internet from clients such as 

HOBLink J-Term or HOBLink JWT. Preferably placed in the DMZ, HOB 

WebSecureProxy protects your servers effectively from direct access over the 

Internet and forwards the queries to the target server.  

Communications bet ween the WSP and the client are SSL encrypted, while  the 

WSP communicates to the server side without using SSL. Data traffic takes 

place over the configurable port 443, which is enabled as default in most 

firewalls. 
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1.2.2.  HOB Web Server 

The WSP comes with an integrated Web server. After installation, the user must 

logon over a secure HTTPS connection to WSP using this Web server (see 

Section 8.1 Scenario: Default Configuration, page 71). The user must be 

authenticated the first time the WSP Web server default HTML page is called up.  

 

For further information, please see Section 3.7 Authentication, page 35  

1.2.2.1. HOB RD VPN Web Server Gate 

This component provides  SSL encrypted access to  Web servers in the enterprise 

network over the Internet. 

 

For further information, please see Section 6.1 HOB RD VPN Web 

Server Gate, page 65 

1.2.2.2. HOB HTTP Redirector  

The HOB HTTP Redirector causes all HTTP queries coming from the browser 

(over port 80) to be redirected automatically to the HTTPS port 443, at which the 

HOB Web Server is listening. 

This component is installed as an EA Server plugin (in HOB EA Administration: 

menu EA Server > Configure, tab Server plugins).  

 

Please refer to the online help for further information on the 

configuration and use of the HOB HTTP Redirector. 

 

1.2.3.  HOBLink J -Term and JWT 

HOBLink J-Term is the multi-protoco l-capable client application for accessing 

host systems via VT, 3270, 5250, HP700, Siemens 9750 and 97801. 

HOBLink JWT is the RDP client application for accessing Micr osoft Windows 

Terminal Servers. 
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1.2.4.  HOB Enterprise Access  

This component handles the central  user management and smoothly integrates 

the HOB software into the existing enterprise infrastructure.  

 

For further information, please see Section 3 User Management with 

HOB Enterprise Access, page 27. 
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2. Installation  

2.1. System Requirements  

2.1.1.  Server System  

¶ Windows  

supports all Microsoft Windows operating systems from Windows 2000 or 

later  

¶ LINUX 

supports LINUX 32 Bit for x86 processors  and LINUX 64 Bit for 

AMD64/Itanium processors   

 

On LINUX, the kernel version 2.6.5-7 (or higher) ensures a stable 

operation of HOB WebSecureProxy. The use of older kernel versions is 

to be avoided, as limited functionality can result. 

¶ Solaris 

HOB RD VPN can only be installed on 64 Bit machines (AMD64/SPARC 

processors or better) with the Solaris 64 bit operating system installed, and 

that have the 64 Bit version of Java 1.6 as a minimum. 

¶ LINUX on zSeries, IBM AIX and HP -UX 

Supported only on request, not as standard . Please contact HOB 

International Sales and Support for more informat ion on this topic.  

 

Requirements 

¶ If HOB RD VPN is to be installed without a Java Virtual Machine, then JVM 

Version 1.5 or higher must be installed on the server  

¶ At least 512 MB RAM 

¶ At least 500 MHz CPU 

¶ Approximately 450 MB of hard disk space 

This value is for a typical installation and depends on the operating system in 

use 

 

It is the responsibility of the server administrator to ensure that the 

operating system in use is adequately conf igured and updated with the 

latest patches and releases to the most efficient operation, and to 

minimize the risks from exploitation or attacks from external sources.  
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2.1.2.  Client System  

On the client side, any browser with Java Version 1.4.2 is supported, b ut HOB 

recommends that Java version 1.5 or higher be used. 

Supported Java 2 compatible browsers /Java 2 browser PlugIns  

The following list is not exhaustive and contains only some of the browsers  

supported : 

¶ Firefox 

¶ Microsoft Internet Explorer  

¶ Safari 

 

Required Browser Settings  

Apply the following settings in the browser to avoid any possible conflicts or 

problems: 

¶ Accept cookies . These are required to run the authentication process . 

¶ Enable JavaScript. This is required to properly display HTML pages.  
 

 

If HOBLink J-Term or HOBLink JWT is running on a PC under 

Windows Vista or Windows 7, please note the following:  

Files created or edited with HOBLink J -Term/JWT on the local PC may 

not be visible to other programs (e.g. Windows Explorer). These files 

are written to a temporary cache administrated by Windows operating 

systems.  

There are two possible solutions to this problem:  

1. Add the HOBLink J-Term/JWT URL to Trusted Sites. 

In Internet Explorer select the menu Tools > Internet 

options > and then the tab Security. Select Trusted Sites, 

click Sites and add the desired URLs. 

2. Switch off Protected Mode .  

In Internet Explorer select the menu Tools > Internet 

options > and then the tab Security. Select Internet and 

deactivate Enable protected mode . 

 

 

It is the responsibility of the administrator of the client machine 

(normally the user personally) to ensure that the operating system in 

use is adequately configured and updated with the latest patches and 

releases to the most efficient operation, and to minimize the risks from 

exploitation or attacks from external sources.  
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2.2. How to Install HOB RD VPN  

1. Insert the HOB RD VPN DVD into the CD-ROM/DVD-ROM drive. If the DVD 

start image does not automatically appear then open the file start.htm  in 

the root directory  of the DVD. 

2. The HOB RD VPN start page opens in the browser. Click Install  Software 

(the link Product Information  links you to data sheets on the HOB products 

involved in RD VPN). 

3. On the next page, click Install HOB RD VPN to start the installation process.  

4. In the dialog Warning ® Security , click Yes or Always  to accept the 

certificate and continue with the installation.  

5. Click Op]npĖEjop]hhanĖbknĖSej`kso  and follow the instructions onscreen.  

6. Preparations for the installation are carried out automatically.  

 

 

In the dialog HOB Software  ̄Product Key you have two options : 

A. One is to Enter a valid key. You can find the key in the document 

HOB Software License delivered along with the product CD or, if 

purchased online, in the e-mail received once payment has been 

confirmed.  

B. Alternatively you can click Evaluation Version. This allows you to run 

the software for 30 days.  The time remaining in the evaluation period is 

displayed. Once this has expired, you must enter a valid product key 

to continue using the software.  

Click OK to close this dialog box.  

 

Read the HTML document First Steps, which opens immediately once the 

installation process has been completed.  

 

2.3. Changing from Local Configuration to Remote 

Configuration  

While installing HOB RD VPN you can decide to configure the  HOB WSP either 

locally or remotely.  

The following descrip tion proceeds from the assumption that HOB RD VPN 1.4 

with the local configuration mode is installed and you want to switch to a  remote 

configuration. 

 

If you have updated an older version of  HOB RD VPN to 1.4, the local 

configuration variant will be installed. In this case, follow the procedure 

described below to change to the remote configuration  variant.  

1. Open the configuration program  HOB Enterprise Access (EA) 

Administration (see Section 3.2, The HOB EA Administration 

Configuration Program, on page 28). 
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2. If it does not already exist, create a container with the name rdvpn one 

level below the root element  firm (click firm with the right mouse button  > 

Add item). 

3. In the newly created container rdvpn, create an object with the name  

websecureproxy . The objects and/or containers can be freely chosen.  

 

When you create an object, you will be prompted to assign a 

user as object manager. Select for example the user 

Administrator (administrator,users,firm) as object manager. 

4. Start the Startup Options Manager by clicking Utilities > Startup 

options¡ and open the file  
<INSTALL_DIR> \ easerver \ WspAssistStartup.xml  

If this file does not yet exist, cr eate it now. 

 

If you are making this configuration remotely  (e.g. if HOB RD 

VPN has been installed on a system without a GUI ), proceed 

as follows: 

¶ Start HOB EA Administration (see Section 3.2 The HOB 

EA Administration Configuration Program , on page 28) 

on the RD VPN Server 

¶ Open the Startup Options  Manager (Utilities > Startup 

options¡) 

¶ Select the connection model via EA Server and click the 

 (browse) button for file selection . 

¶ From the list now displayed, select the file  
WspAssistStartup.xml  
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5. In the Startup Options manager select the  Connection model  tab. 

In the tab Connect to database , select the option via EA Server.  

 

6. Select the tab Logon. 

Enter the User name, Password and User context  of the object manager 

from the WebSecureProxy (see above), activate Use object management  

and in the field Object name/Context enter the name of the 

WebSecureProxy object .  
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7. Select the tab Options. 

Activate the option Use AutoLogon (by default this is not slected).  

 

 

8. Select the tab Connection. 

In the field EA Server Address: enter the value localhost and in the field 

EA Server Port: enter the value 13270, as shown below. 
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9. Save the file (File > Save) and close the Startup Options Manager. 

10. Returning to EA Administration, right click  the object websecureproxy  to 

open the WSP configuration program and then click   

Configure > HOB RD VPN > WebSecureProxy. You will see the following 

screen: 

 

 

11. Import  the HOB WSP configuration file by selecting  

File > Import  

and then select the following file : 
<INSTALL_DIR> \ wsp\ wsp.xml  

 

If you are making this configuration remotely ( for example if 

HOB RD VPN has been installed on a system with no GUI), 

first copy the file wsp.xml  via file transfer to the local PC 

and then import the file from this location . 

12. Save the file by clicking File > Save. 

If a dialog box appears asking whether the settings should be made 

effective immediately, click No. 

13. Close the WSP configuration p rogram. 

14. In EA Administration select 

EA Server > Configure 

and then the tab Server plugins. 
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15. If the server plugin HOB WebSecureProxy Agent has already been 

created, skip to step 24. 

If the server plugin HOB WebSecureProxy Agent has not already been 

created, proceed with  steps 16-23. 

16. Close the dialog box and EA Administration. 

17. Under Windows open the Windows program Services. 

(Start > Control Panel > Administrative Tools > Services)  

 

 

18. Under Windows stop the service HOB WebSecureProxy. 

Under Linux/Unix: Stop the program websecureproxy.   

 

19. Under Windows deactivate the service HOB WebSecureProxy.  

Under Linux/Unix: Remove the startup script that starts the HOB 

WebSecureProxy. 

20. Under Windows open the Windows program Services. 

(Start > Control Panel > Administrative Tools > Services) and stop the 

service EA Server.  

Under Linux/Unix: Terminate the program easerver (see Section 3.2  

The HOB EA Administration Configuration Program, on page 28).  

21. Open the file <INSTALL_DIR> \ wsp\ hlserver.xml with a text editor .  

22. Add the following code after the tag <server_plugins> and directly in front 

of the tag </server_plugins>: 
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  <wsp_assistant>  

  <name>HOB WebSecureProxy Agent</name>  

  <run>Y</run>  

   <classname>hob.wsp.assist.wsp_assistant</classname>  

   </wsp_assistant>  

23. Save the file hlserver.xml, start EA Server and re-open the dialog Server 

Plugins in EA Administration (see step 14 above). 

24. Activate the Start server plugin checkbox for the HOB WebSecureProxy 

Agent. 

25. Close the dialog. You will be asked when the new settings are to take 

effect. 

If Now is selected, the EA Server and the WebSecureProxy are restarted 

automatically with the new settings.  If After Restart is selected the EA 

Server can be restarted manually at a later time. 

26. Rename the following file: 
<INSTALL_DIR> \ portal.db \ local .xml  

to:  
<INSTALL_DIR> \ portal.db \ remote .xml  

2.4. Changing the IP Address /Port  

If you want to change the  IP address or port (e.g. change the address to 

myserver.mydomain.com, and the port number to e.g. 443) on an existing HOB 

RD VPN installation, please follow these instructions : 

2.4.1. Changing the incoming port  

1. Start the HOB WebSecureProxy configuration program  

(See Section 3.9, Configuration Program for H OB WSP, on page 36). 

2. Select the connections template  to be used, or add a new template by using 

the Add button, e.g. Connections > SELECT. 

3. Change the value of the entry Incoming port on the tab Incoming connection  

to the required port , for example to port 443 . 
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2.4.2. Changing  the address of the I ntegrated Web  Server 

1. Select Integrated Web Server 

2. Select the tab Web server.  

3. Change the value of the Web server address as desired. 

 

2.4.3. Configuring  the HTTP Redirector  

If the HTTP Redirector is being used follow these steps: 

1. Start HOB EA Administration 
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2. Start the HOB EA Server configuration program.  

(EA Server > Configure...) 

3. Select the tab Server plugins. 

4. Change the hostport and address parameters for the HOB HTTP Redirector.  

 

2.4.4. Changing  the Startup Options  

1. Open the Startup Options Manager (Utilities > Startup options). 

2. Open the startup options file . Change the startup options files  of HOBLink J-

Term, HOBLink JWT, HOB EA Admin and HOB EA Admin extern in the 

sequence they are to be used. 

3. Select the tab WSP/HTTP Proxies. 

4. Change the address and port of the  WebSecureProxies you are using. 
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2.5. Customizing HOB RD VPN  Web Pages 

The HOB RD VPN user pages (e.g. the login page) can be customized . For 

example, you can integrate your own logo or adapt the text used onscreen to 

those of your website . 

Replacing the banner 

 

The banner (banner_rdvpn.jpg) is stored in the following two director ies:  

¶ <install_d ir>/www/login/ i   

¶ <install_dir> / www/i  

Replace these files with a .jpg file of your choice (the .jpg file must have a size of 

871 x 98 pixels). 
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Pcnj_agle rfc rcvr ¬HOB RD VPN Jmegl­ ml rfc jmegl n_ec 

 

Open the file <install_dir>/www/login/login.html , and in the line 
msgL="HOB RD VPN Login "  

replace the text be tween the quotation marks with  text of your choice . 

 

Pcnj_agle rfc rcvr ¬HOB RD VPN Logout­ ml rfc jmemsr n_ec  

 

Open the file <ins tall_dir>/www/login/logout.html , and in the line 

msgL="HOB RD VPN Logout ";  replace the text be tween the quotation marks 

with text of your choice . 
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2.6. Uninstallation  

HOB RD VPN can be uninstalled via the Windows operating system uninstallation 

function.  

¶ For example, on Windows operating systems: 

Click Start > Control Panel > Software > HOB RD VPN > Change/Remove 

and then click Uninstall.  

After carrying out the step above, you may have to restart your system to 

complete the uninstallation.  

2.7. Saving Installation and Configuration Data  

For reasons of security, before carrying out a software update or installing a new 

release/version, we recommend that you save the existing HOB RD VPN 

installation. This can help you restore the installation  if necessary to its previous 

state with a minimum effort.  

You would usually do this by creating a backup copy of the complete HOB R D 

VPN installation folder e.g. C: \ Program files \ HOB\ rdvpn  (default installation 

path) and placing this copy on a suitable da ta carrier. 

Alternatively, you could make a selective backup by copying only the relevant 

folders and files. These files you can find in the following table:  

Folder /File Content  

. \ easerver   Configuration data of the EA Server  

. \ portal.db  Configuration data of the user (Enterprise 

Access Database) 

. \ sslsettings  SSL-Server certificate 

. \ wsp\ wsp.xml  HOB WebSecureProxy configuration data  

Note: If you use the HOB WSP agent (see User 

Management with HOB Enterprise Access  on 

page 27) the WSP settings will be written from 

LDAP or HOB Enterprise Access and this file 

will be overwritten at startup.  

. \ www\ lib \ sslpublic  SSL-Client certificate  

. \ www\ lib \ hob \ props  Startup option files of the client 

. \ www\  In this folder, save any changed or custom 

HTML pages (and JavaWebStart files) 
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3. User Management with HOB Enterprise Access  

HOB RD VPN is completely integrated into the HOB Enterprise Access concept. 

With HOB Enterprise Access, administrators  can centrally manage user settings 

and configuration data. Users are displayed in a hierarchical group and tree 

structure, truly simplifying administration, especially when there are a great many 

users to manage. 

Thanks to the LDAP server support, a feature of HOB Enterprise Access, the 

time-consuming individual creation and maintenance of many user profiles is a 

thing of the past. HOB RD VPN users thus benefit from the many advantages of 

the HOB Enterprise Access idea, for example: 

¶ Central configuration  

¶ Central administration 

¶ Central management 

¶ Inheritance of schemes and user settings  

The configuration files for HOB RD VPN users can be stored locally in the HOB 

Enterprise Access database, or in the LDAP database. This data is then 

accessible over either the HOB Enterprise Access Server (EA Server) or the LDAP 

server. HOB Enterprise Access uses a tree structure; the elements it contains 

pass their properties to lower -level elements in the tree. 

3.1. The HOB EA Concept  

HOB Enterprise Access (HOB EA) is a product that gives you the utmost 

flexibility in the centralized management (Single Point of Adm inistration) of HOB 

Connectivity Clients (HOBLink J-Term/JWT). This configuration program is 

installed automatically on the HOB RD VPN server, which acts as a server PC. 

On this server PC (also known as the EA Server), the user settings of the HOB 

clients are stored in a database, to which the users must log on. After logon, the 

user settings are downloaded from this database via TCP/IP. This process in turn 

allows users to start those applications for which they have authorization.  

The two configuration sc enarios described below can be implement ed by HOB 

EA in combination with HOB Connectivity Clients:  

¶ Connection over the EA Server (Standard configuration) 

(see 8.1 Scenario: Default Configuration, page 71) 

All user settings are placed in a database on the EA Server. As soon as you start 

HOB RD VPN or HOB EA Administration (the central administration tool of HOB 

RD VPN 1.4), you are connected to the EA Server. 

 

The EA Server is installed as a Windows service that starts 

automatically (Start > Control Panel > Administrative Tools > Services). 
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¶ Connection to an LDAP server via the EA Server  

In this scenario, HOB RD VPN goes over the EA Server to access the user data 

on the LDAP server. As default, the EA Server communicates with the LDAP 

server over port 389. 

 

For further information in th e configuration of connection models, 

please see the online help of the Startup Options Manager from HOB 

EA Administration (Utilities  > Startup options... ). 

3.2. The HOB EA Administration Configuration Program  

HOB EA Administration is a Java-based application that automatically is installed 

together with HOB RD VPN. 

During the installation of HOB RD VPN you can decide how, as an administrator, 

you want to work with HOB RD VPN (and so with HOB EA Administration) in 

order to make configurations. There are two possible methods:  

¶ Local configuration  

where the administrator works only on the local system  

¶ Remote configuration  

where the administrator works remotely over the network  

3.2.1. HOB EA Administration ® Local Configuration  

Proceed as follows to start HOB EA Administration with the installation option 

Local Configuration : 

Launch HOB EA Administration by clicking one of its shortcuts. You  can find 

these shortcuts in the following directory:  

- under Windows: Start > All Programs > HOB RD VPN > Administration 

- under Linux/Unix: / home / your_username / HOB RD VPN > Administration 

3.2.2. HOB EA Administration ® Remote Configuration  

Proceed as follows to start HOB EA Administration with the installation option 
Remote Configuration: 

¶ With a browser, open the HOB RD VPN initial page and log in as an 

administrator.  

¶ Click the link Administration  Tools. 

¶ Click Start HOB EA Administration or Start HOB EA Administration from 

Intranet.  

If you work over the internet use the link Start HOB EA Administration. In 

this case some configuration options are not available, e.g. the shutdown 

of HOB WebSecureProxy. If you work in the same network, use the link 

Start HOB EA Administration from Intranet. In this case a direct 

connection to the EA server (port 13270) has to be available.   
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Once the security queries have been satisfied for these configuration methods , 

HOB EA Administration will open and you will see the following screen: 

 

3.2.3. Working with  HOB EA Administration  

With HOB EA Administration you can do the following : 

¶ Configure the HOB EA Server, which administrates the  user settings in the 

database. 

¶ Create and administer the database elements e.g. users, groups and 

containers, and their properties . 

¶ Configure the HOB EA applications . 

¶ Determine the startup options  that contain the basic settings for logging onto 

the database and for the connection to the  EA Server. 

¶ Configure the user rights and inheritance methods.  

A Brief Description of the Database Elements  

The following Section briefly describes the main organizational elements used in 

Enterprise Access Administration when you are making your configuration via the 

EA Server (Connection model: Via EA Server). If you use an LDAP server 

(Connection model: Via LDAP), these elements are replaced by the organizational 

elements of the LDAP server. 

 Firm 

This is the root element and it represents your organization. It is already part of 

the database when you run HOB EA Administration for the first time and cannot 

be created by t he user or administrator. The root element is the basic level of the 
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database. It takes the first position in the tree structure  ̄all other elements are 

on sublevels. 

 Container  

Containers are abstract elements. They are meant to be organizational units that 

make it possible to keep the database clearly structured. Therefore do not use 

containers to represent real persons. Containers can be expanded.  They can 

contain other elements on sublevels, which in turn may be either groups or other 

containers. 

Object  

Objects are abstract elements. Do not use ob jects to represent real persons. 

Practical examples for using objects are to define gateways or proxies. Objects 

represent the lowest level of the tree. Objects cannot be expanded or enhanced. 

Therefore, they cannot accommodate other elements on sublevels the way 

containers do.  

 Group 

Use this element to represent departments in your enterprise. Groups cannot be 

expanded or enhanced. Therefore, they cannot ac commodate other elements on 

sublevels the way containers do. However, you can assign existing users in the 

rpcc rm epmsnq _q kck`cpq _lb rfsq ¬`slbjc­ rfck, Rfgq gq lmr _afgctcb `w

physically adding elements to them, but simply by configuring either the group or 

user properties accordingly.  

 User 

Use this element to represent real persons. Users represent the most basic 

element of the tree. Users cannot be expanded or enhanced. Therefore, they 

cannot accommodate other elements on sublevels the way containe rs do. 

You can, however, organize existing users into groups. This is not achieved by 

physically adding elements to them, but simply by configuring either the user or 

group properties accordingly.  

3.2.4.  Remote Management  

As an administrator you can carry out se veral HOB EA Administration 

management tasks remotely over a network .  

The Remote Management utility allows the following operations to be carried out 

remotely: 

¶ Update HOB RD VPN software 

¶ Update SSL Certificates 

¶ Update the HOB license key 

 
Proceed as follows to open the Remote Management utility: 
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1. Open the HOB RD VPN initial page with a browser and log in as an 

administrator.  

2. Click the link Administration Tools . 

3. Click the link Start HOB EA Administration and enter your credentials. 

4. HOB EA Administration will open. In the menu select 

Utilities > Remote Management . 

5. The Remote Management Dialog will appear: 

 

 

 

 

For security reasons we strongly recommend that the Remote  

Management utility requires the administrator to login using a client 

security certificate  (See section 13 Security with SSL and TLS, page 

105). Alternatively longer, case sensitive passwords may be used. 

Information about the Remote Management utility can be found in the 

online help. 

 

3.3. HOB RD VPN User Settings  

With the HOB EA Administration program you configure basic settings 

concerning the access to HOB RD VPN that are assigned to a database item 

(user, group or firm). These settings are for example: 

¶ HOB RD VPN initial page 

¶ Enabling HOB RD VPN 

¶ Enabling HOB RD VPN Web Server Gate 

¶ Enabling the integrity check (access to HOB RD VPN will be denied if no 

current virus scan program is installed on the client) 

¶ Enabling Anti Split Tunneling 



User Management with HOB Enterprise Access  ___________________________ HOB RD VPN 

32 Security Solutions by HOB  

How to define the HOB RD VPN User Settings  

1. Start the HOB EA Administration configuration program.  

2. Logon to HOB Enterprise Access. 

3. Select the database item (user, group or firm) for which you want to 

create/edit the configuration.  

 

To assign the same settings to all database  items in one step, select 

the base item  in the database. 

4. Right-click the desired element and select Configure > HOB RD VPN > User 

settings. In the diagram below the settings for a user, in this example named 

¬guest­, are shown. 

 

5. Make the desired settings . 

6. Click OK to save the settings and to close the dialog box.  

7. Close the HOB EA Administration program.  

 

 

For every database element to which no initial page is assigned in that 

manner, the initial page configured in the HOB WebSecu reProxy 

configuration (initial page after authentication) will be used. ( Server 

Lists  > tab Server Configuration  > Mode: Integrated Web Server ). 

 

 

For more detailed information, see the online help.  
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3.4. HOB EA Server  

The HOB Enterprise Access (EA) Server is one of the basic components of HOB 

Enterprise Access and is normally installed on the server computer. It is an 

application without a GUI that runs invisibly in the background (on Windows 

operating systems as a service). The EA Server can run on all operating systems 

having a Java Virtual Machine 1.3 or higher. 

The EA Server executes the following tasks: 

¶ Administrating the EA database containing all user -related settings 

¶ Verifying user rights 

¶ Providing the respective user settings for e ach HOB EA Application 

The EA Server responds to TCP/IP connections established by the HOB 

Connectivity Clients . TCP/IP connections can be established over two ports, 

depending on the connection type used:  

Port 13270 (default) for conventional connections  

Port 13271 (default) for secure SSL connections 

The connections between the EA Clients and the EA Server are not permanent, 

since a huge number of client -server connections would drastically increase the 

load on system resources. Once a client has been launched, a connection to the 

EA Server is established for a certain period of time (Timeout). After the specified 

time has elapsed, the connection will be terminated automatically. If the EA 

Server is re-accessed later on (e.g. to save user settings), the connection will be 

automatically restored (executed in the background  ̄imperceptible to the user).  

If you are using an LDAP database instead of the EA database, the EA Server 

acts as a proxy server to the LDAP database. For more information, please see 

Section 3.5 LDAP Considerations below. 

3.4.1.  Starting  and Stopping  the EA Server 

The EA Server is installed as a service (Windows) or Startup Script (Linux/Unix)  

and started automatically at system startup.  

If required (e.g. after changing its configuration) you can start or stop the EA  

Server manually. 

Under Windows 

If necessary, check the current state  (nominal value: started) and auto-start type 

(nominal value: automatic) under Control Panel > Administrative Tools > Services 

and make the required settings . 

Under Linux  

If no Startup Scripts were installed, you can start these programs manually at 
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any time by executing the following file : 

<installdir> /EAServer . 

3.5. LDAP Considerations  

If your organization deploys an LDAP server to manage user accounts, you may 

also use HOB Enterprise Access with LDAP. The user-specific settings of the 

HOB Connectivity Client will then also be stored on the LDAP server.  

If you want to enable your users to individuall y adapt application -related settings, 

they must have the corresponding rights on the LDAP server. All HOB 

Connectivity Clients use one or more HOB -specific attribute; the users must 

have read and write rights for these attributes set for them on the LDAP s erver. If 

they do not have these rights, an error message will appear no later than after 

termination of the application, stating that the user has no authorization to 

change settings and that the changes cannot be saved . 

To deploy user administration over  LDAP, you will have to carry out a schema 

extension on the LDAP server that contains the HOB object classes hoboc  and 

hobgateway . These are used to save the user settings of the HOB Connectivity 

Clients. 

 

For further information, please see HOB LDAP Scheme Extension in 

the HOB EA Administration online help (this hyperlink will only function 

if you have RD VPN installed and are reading this manual from the 

installation folder ). 

3.6. Startup Options Manager  

The Startup Options Manager performs a number of tasks. Its user interface 

varies depending on its current settings. This Section deals only with tasks 

relevant for RD VPN, e.g. creating or editing the start options for an HO B 

Connectivity Client.  

 

For more information, see the online help for Startup Options Manager . 

 

The startup options determine the settings that are used when executing the 

HOB Connectivity Clients as well as the connectio n model used for this.  

The startup options can be used to configure a wide range of authorization 

models for user logon, from very restrictive to very free. For example, the user 

can be logged on without having to enter logon credentials by setting the HOB  

Connectivity Client to start automatically. Or you could give experienced users 

more room for personal decisions by allowing them to logon with various user 

names and alternative logon options.  

../entpradmin/ExtrasLDAPSchemeExt.html
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The Startup Options Manager is started by clicking:   

¶ Start > All Programs > HOB RD VPN > Administration > Startup Options 

Manager 

 

Or alternatively: 

 

¶ Start > HOB EA Administration  > Utilities > Startup Options Manager  

 

 

3.7. Authentication  

Rfc npmacqq md tcpgdwgle _ ncpqml«q gbclrgrw ml rhe basis of specific 

characteristics is known as authentication. User names and passwords, tokens  

and SmartCards, for example, are often used for authentication.  With HOB RD 

VPN, authentication can be carried out in various ways:  

¶ Via a RADIUS server 

¶ Via LDAP 

¶ Via the EA Server (local database) 

3.7.1.  RADIUS Server Authentication  

If your enterprise has a RADIUS server at its disposal, you can use it as an 

authentication server and correspondingly configure HOB RD VPN to 

authenticate via user name and password or so -called key tokens (optional). 

 For a graphic depiction of this scenario and de tails of the configuration, 

please see 8.2.4  Scenario 4: RADIUS Authentication via Tokens, page 82. 

3.7.2.  LDAP Authentication  

If your enterprise deploys an LDAP system for user management, you can 

integrate HOB RD VPN into this environment as well. 

 For an illustration of this application scenario and details on the configuration, 

please see 8.2.5  Scenario 5: RADIUS Authentication/LDAP User Management, 

page 84, and also: 

 For an illustration of this application scenario and details on the configuration , 

please see 8.2.6 Scenario 6: Authentication to IAS from MS Active Direct ory 

Without an LDAP Scheme Extension, page 85. 
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3.7.3.  EA Server Authentication  

If your enterprise does not deploy either a RADIUS server or an LDAP system, 

you can still have your users authenticate themselves via user name and 

password with HOB RD VPN. Once HOB RD VPN has been installed this 

function is active as default.  

 For an illustration of th is application scenario and details of the configuration, 

please see 8.1.2  Startup Options Manager/HOBLink JWT, page 75. 

3.8. Single Sign-On 

Windows operating systems can use a Single Sign -On function for logging on to 

HOB Enterprise Access as well as to HOBLink J-Term/JWT. When the user logs 

on, the Windows user name and password (for HOBLink JWT the domain also) 

appear automatically in the corr esponding input fields in the logon dialog box.  

To use this function, you have to install the HOB Single Sign -On extension on 

each client PC. 

 

Single Sign-On currently is only supported for Windows XP. 

3.9. Configuration Program for H OB WSP 

While installing HOB RD VPN you can decide how you want to configure the 

HOB WSP. There are two methods to choose from:  

¶ Local configuratio n 

¶ Remote configuration  

3.9.1.  Local Configuration of the HOB WSP  

On installing HOB RD VPN you have a graphical user interface for configuring the 

HOB WSP. 

¶ To open this GUI, click:  

Start > All Programs > HOB RD VPN > Administration  > Configure HOB 

WebSecureProxy 

The GUI window is divided into two panes (see  the diagram below): 

1. The tree structure on the left, in which the configuration is divided into logical 

units. At the top left of the window the name of the currently  selected WSP 

configuration file (XML-format), including its path in the application directory, 

is displayed. 
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2. Dynamically changing tabs in the right -hand pane, which are displayed 

according to the scheme currently selected in the tree structure on the left . 

These contain the control elements (checkboxes, input fields, etc.) used to 

make the required settings.  

 

On the tabs that are included on this GUI you can access all the settings that can 

be made for the WSP. For example the Outgoing Connection  tab (which 

appears when you click on a connection defined in the Connections scheme) 

allows you to choose and configure one of the various connection modes that 

can be configured for the WSP:  

¶ 1:1 Gateway 

In this mode there are various connection protocols availabl e to you (e.g. 

Telnet and RDP) for connections to 3270 hosts or Windows Terminal Servers. 

¶ WSP on WTS 

This mode is required for connections when the HOB WebSecureProxy is 

installed on a Windows Terminal Server. 

¶ WTS Load Balancing  

This mode is designed for enterprises that use Windows Terminal Server 

farms. The Load Balancing component distributes the sessions over the 

server farm to the various Windows Terminal Servers, optimally utilizing their 

capacity.  

¶ VDI (This option is only available if Support VDI mode is selected on the VDI 
tab in the Settings  scheme.) 
This mode is designed for connections to blade  servers running Windows 

operating systems and remote-desktop-support.  

 For further information, see Section 10 HOB VDI Business, page 97. 
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¶ Deskto p on Demand  

This mode is designed for connections to remote workstations running 

Windows operating system s and remote-desktop -support.  

 For further information, see Section 9, HOB RD VPN Desktop-on-Demand, 

page 89. 

¶ Server Lists  

This mode is designed exclusively for connections to the HOB Connectivity 

Clients HOBLink J-Term and HOBLink JWT. By creating so-called Server 

Lists, which determine the protocol as well as the terminal of a connection, 

users are automatically assigned and connected to the sessions that are best 

suited for their needs. These are configured on the Server configuration  tab 

(which appears when you click on one of the servers defined in Server List s) 

where you can choose and configure one of the above -listed connection 

modes. However, under this mode, the mode WSP on WTS cannot be 

selected, but instead you have the possibility  to select the Integrated Web 

Server mode. 

 

For more information, see the online help for this tool . 

 

Starting and Stopping the WSP  

The HOB WSP is installed as a service (Windows) or Startup Script (Linux/Unix)  

and started automatically at system startup.  

If required (e.g. after changing its configuration) you can start or stop the HOB 

WSP manually. 

Under Windows 

If necessary, check the current state (nominal value: started) and auto -start type 

(nominal value: automatic) under Control Panel > Administrative Tools > Services 

and make the required settings.  

Under Linux  

If no Startup Scripts were installed, you can start these programs manually at 

any time by executing the following file:  
<installdir> /wsp/run_hobwsp.sh  

3.10.  Remote Configuration of the HOB WSP  

In addition to  the local configuration method for the HOB WSP, a remote 

configuration using HOB EA Administration is also possible. This is the case 

when, during installation, the option remote was selected. The remote 

configuration is performed in a very similar way to a local configuration.  
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How to start the remote configuration of the HOB WSP  

1. Start HOB EA Administration 

2. Select the object that represents the HOB WebSecureProxy.  

3. Right click the element and select  Configure > HOB RD VPN > 

WebSecureProxy. 

The configuration program for the  HOB WSP will open (please see the 

diagram above). 

4. Information on the elements in this configuration program can be found in 

the preceding section.  

 

Starting and Stopping the HOB WSP  

With the remote configuration the WSP is started and stopped via the  

configuration npmep_k«s menu. 

 

For reasons of security, the HOB WebSecureProxy configuration 

program can only be started or stopped when the r emote PC is within 

the enterprise network . This cannot be done over the Internet. 

You have the following options from the menu  WSP > Configure > Management: 

¶ Start server to start the server 

¶ Stop server to stop the server  

¶ Restart server to stop and then start the server again, to reload the data  

¶ Refresh to reload the data on the server, without stopping the server from 

running. 

3.10.1.  WSP Remote Configuration  ® Mode of Operation  

HOB WebSecureProxy can be remotely configured using  HOB EA 

Administration. The configuration can also be changed while the software is 

running. The HOB EA Plugin WSP Agent, included in the scope of delivery, is 

used for this. 

The HOB WebSecureProxy configuration can be saved either in the  HOB EA 

database or in an LDAP directory.  

When the configuration of the HOB WebSecureProxy has been changed, it will 

be started with the new parameters . All existing sessions will remain connected 

and running  ̄however, with the old parameters . Only when a session is 

reconnected will the new parameters be applied . 

The diagram below shows how the  WSP Agent works: 
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1. Using HOB EA Administration, new settings for the WebSecureProxy are 

made over the HOB EA Server and written to the  EA database or an LDAP 

directory. 

2. HOB EA Administration informs the WSP Agent that the configuration has 

been changed. 

3. The WSP Agent reads the changed configuration .  

4. A new instance of the HOB WebSecureProxy with the new parameters is 

started. 

 

Please note that there must be a network connection between HOB 

EA Administration and the HOB WSP Agent in order for the remote 

configuration to be carried out . 
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3.11.  Saving the HOB RD VPN Configuration in LDAP  

This Section contains instructions on how to save the  HOB WSP configuration 

file in an LDAP directory . In this description, Microsoft Active Directory is used as 

the example LDAP server. The basis of this description is a completed  HOB RD 

VPN installation with the  HOB EA configuration stored in Active Directory.  

1. Open the configuration program  EA Administration (see Section 3.2, The 

HOB EA Administration Configuration Program , on page 28). 

2. Carry out a schema extension. To do this, select the menu items  Utilities 

> LDAP Scheme Extension > Microsoft Active Directory  

3. In the dialog box that then opens select  Extend schema for HOB EA. 

 

 

4. Another dialog box will appear in which you select the  EA Object class. 

Select the entry HOB Gateway Schema Extension and click OK. 

5. When the schema extension is carried out successfully, a  confirmation 

message will appear. 

6. In LDAP, create a gateway for the WSP. To do this, start the program  

Active Directory-Users and C̄omputers and create a suitable structure.  

7. In this description, a sample structure will be used, in which the 

organizational unit HOB will contain the organizational unit  Gateways, 

which contain s the object wspserver1:  

 
- HOB 

 - Gateways  

 - wspserver1  

 

The object wspserver1 represents the HOB WebSecureProxy. If several 

WebSecureProxies are being used, it is recommended to name th e 

gateway accordingly, e.g. with the name of the server on which the  WSP 

is running. The gateway is created via Right mouse click > New > 

hobgateway. If there is no hobgateway, the HOB gateway schema 

extension was not correctly carried out . 

8. Now it is possi ble to access LDAP with  EA Administration. All of the 

following steps can be made via remote logon to  HOB EA Administration.  

In HOB EA Administration start the Startup Options Manager  

(Utilities > Startup optionq¡). 
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9. Select the item EA Administration startup options file and click Open. The 

Startup Options Manager will open. On the Connection model  tab select 

Connect to database via  LDAP, as shown below.  

 

10. Select the Connection tab (see diagram below) and enter the values for 

the connection to the  LDAP server. 
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11. In HOB EA Administration connect to the  LDAP server (menu File > 

Connect) and logon. 

 

 
 

The structure of the LDAP server will be displayed in HOB EA 

Administration.  

12. Import  the existing configuration to LDAP. To do this, right -click the 

object d epicting the  WebSecureProxy and select Configure > HOB RD 

VPN > WebSecureProxy. If a message appears, click OK. 

The WSP configuration program will open. 

13. Select File > Import and open the currently used c onfiguration file 

wsp.xml . 
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Click Open to import th e file and open it. 

14. Save the imported file by clicking the File menu > Save. You will see a 

message confirming the WSP configurations have been saved. Click OK. 

15. A dialog box will open asking whether you  want to update the settings 

immediately. Click No. 

16. Close the WSP configuration program . 

17. Temporarily set the EA Server to the connection model  EA Server. This is 

done by selecting via EA Server in the Startup Options Manager on the 

Connection model  tab. 

18. In the EA Administration menu bar, select EA Server > Configure.  

19. Logon using the default user name of administrator  and the default 

password of adminpw.  

 

Please note that these are a default username and password only, and 

should be changed for a more secure logon setting at the earliest 

opportunity.  

20. On the Properties tab, select the option LDAP database in the Database 

in use field. 
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21. On the LDAP connection tab, enter the values for the LDAP server being 

used and click OK. 
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22. Now you need to c reate an Administrator/Search user logon . On this next 

screen, enter the relevant data and click OK to save the data and close 

the dialog.  

 

 

23. Click OK in the EA Server configuration window to save your settings and 

close the window . 

24. You will see a message stating the default password is still active . You 

should create a new password for the EA Server administrator.  

25. Click the Now button to apply the new settings immediately . 

26. Now connect to the  EA Server using HOB EA Administration. You must 

use the LDAP administrator login information . 

 

 

27. After a successful logon,  in EA Administration the LDAP server structure 

will be shown. 

28. Next, configure the WSP Agent in such a way that it accesses  LDAP. 

There are two ways to do this : 

a. The WSP Agent accesses LDAP directly. This is the recommended 

method. 

=> Follow steps 29 to 35.  
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b. The WSP Agent accesses LDAP over the EA Server. Use this method 

when the LDAP server cannot be accessed directly . 

=> Follow steps 36 to 41. 

29. In HOB EA Administration, open the Startup Options Manager  (Utilities > 

Startup optionq¡). 

30. Select the connection model  via EA Server and, in the installation 

directory, go to the sub -directory easerver and open the file 

WspAssistStartup.xml . 

31. In the Startup Options Manager  select the Connection model  tab select 

the connection model  via LDAP. 

32. On the Logon tab enter the logon information . The user entered must 

have authorization to modify the attribute s hobgwwsp and hobmonitor  

in the WSP object (Recommendation: In the WSP object only authorized 

administrators should have read and write authorization ). 

In the field Object name/Context:  the context should be entered with  the 

base (e.g. DC=firm,DC=local). 

 

 

 

33. On the Options tab, activate the setting  Use AutoLogon (if it is not already 

activated). 
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34. On the Connection tab, enter the connection data for the L DAP server. 

 

 

35. Save the file and (File > Save) and close the Startup Options Manager. 

Now continue from step  42. 

36. If the WSP Agent is to access LDAP over the EA Server, open the Startup 

Options Manager in HOB EA Administration (Utilities > Startup optionq¡). 
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37. Select the option local file and open the file WspAssistStartup.xml  in the 

directory easerver. 

38. In the Startup Options Manager  select the option Connect to database  > 

via EA Server on the Connection model tab. 

 

39. Enter your logon information on the Logon tab. 
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40. On the Connection tab enter the data for the connection to the EA Server.  

 

 

41. Save the file (File > Save) and close the Startup Options Manager . 

42. In the Windows Control  Panel restart the service HOB EA Server. 

43. The configuration should now function . To test this, login again to  HOB 

Enterprise Access. 

 

 

44. Open the WSP configuration program by right -clicking the object 

websecureproxy  and then clicking  

Configure > HOB RD VPN > WebSecureProxy.  

45. If the WSP is running, a green dot in the left -hand column to the left of the 

WSP is displayed. 
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4. HOB PPP Tunnel 

The HOB PPP Tunnel is one of the preinstalled features of HOB RD VPN 1.4. 

These features, referred to as Extensions, are designed to enhance the security 

and usability of HOB RD VPN 1.4, yet due to individual user requirements they 

cannot be activated in every instance.  

The HOB PPP Tunnel enables a remote user (e.g. a business traveler, or 

someone working in a home office) to connect to the enterprise network over the  

Internet. The remote user gains full access to all network resources, just as if 

he/she were working on a machine within the enterprise network . The HOB PPP 

Tunnel is the alternative to classic  IPSec VPNs and has the advantage that no 

additional installation of software on the cl ient machine is required. 

 

The HOB PPP Tunnel requires one of the following operating systems 

to be installed on the client machine:  

¶ Windows Vista 

¶ Windows 7 

¶ Linux 

¶ Solaris 

¶ Free BSD 

¶ Mac OS 

When you start the HOB PPP Tunnel under Linux, Solaris, Free BSD or 

Mac OS for the first time, you must download and execute a utility that 

lets you reconfigure your client system. For this procedure you need 

administration rights  on the client. This utility guides you through the 

configuration process of HOB PPP Tunnel on your client system.  For a 

description of the configuration please see the following section.  

   

 

The diagram below shows how the  HOB PPP Tunnel works: 

 

The only requirement on the client side is that it has  one of the above listed 

operating systems with a Java-capable browser . The server side requires three 

components : HOB WebSecureProxy, HOB PPPT Gateway and a functioning 

L2TP server (e.g. Microsoft RAS Server, Linux L2TPF, Linux XL2TPD or Cisco). 
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4.1. Installation and Configuration  

The following steps are required to set up the  HOB PPP Tunnel: 

¶ Install the HOB PPPT Gateway 

¶ Configuration of the HOB PPP Tunnel in the WebSecureProxy (see next 

section below)  

¶ Configuration of the L2TP server (see Section 4.1.4, below) 

¶ Configuration of the U ser Start page (see Section 4.1.5, below) 

 

4.1.1.  Install the HOB PPPT Gateway  

The HOB PPPT Gateway can be installed on the same physical machine as HOB 

RD VPN, but it is recommended that it be installed on another PC in your internal 

network. 

¶ To install the HOB PPPT Gateway on Windows operating systems 

Run the file \ software \ ppptgate \ HOB PPP Tunnel Gateway 1.2.msi  

that is included on the install DVD of HOB RD VPN 1.4, and follow the 

instructions as given.  

¶ To install the HOB PPPT Gateway on other operating systems 

The program files must be copied manually onto the PC. They are located at:  

ñinstall_dirò\ tools \ ppptgate  

Also included is a Readme file that includes full installation instructions.  

 

4.1.2.  Configuration of the HOB PPP Tunnel in the 

WebSecureProxy  

The first step is to enable the HOB PPP Tunnel in the configuration program of 

the HOB WebSecureProxy. 

1. Start the HOB WebSecureProxy configuration program.  

(See section 3.9, Configuration Program for H OB WSP, on page 36.) 

2. Open the Extensions  > PPP Tunnel scheme at the left of the tree structure . 

3. Check the Enable button at the top of this tab to enable the HOB PPP 

Tunnel. 
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4. In the area PPP Tunnel Gateway enter the Host IP address and Host port of 

the server on which you have installed the PPPT Gateway. This is the IP port 

at which the HOB PPPT Gateway listens for data coming from the 

WebSecureProxy. The default setting is 5556.  

4.1.3.  Using NAT and DNS 

When using the PPP Tunnel, there are certain circumstances under which further 

entries  ̄NAT and DNS  ̄may be necessary. This is the case when you want to 

access systems over the PPP Tunnel that are in different sub -networks to the 

addressed L2TP server. 

In the sample scenario depicted below the servers in subnet 1 are directly 

accessible to the remote client, those in subnet 2 are not. 
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To make these settings use the tabs NAT, DNS, and Exclude DNS in the 

Extensions feature PPP TUNNEL. 

Using NAT   

On the NAT tab you can map specific IP addresses from other subnets  (in the 

example, Subnet 2) in the L2TP server subnet (in the example, Subnet 1). In the 

L2TP server subnet you have to reserve the IP addresses used exclusively for 

this purpose. 

 

1. Click the NAT tab and then the Add button. The dialog Add NAT Entry will 

open. 

2. Enter in the Real Address: field the numerical IP address of the target 

system where this system can be reached within the network  (e.g. 

170.55.22.1). 
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3. Enter in the Translated Address: field the numerical IP address where the 

target computer can be reached once the HOB PPP Tunnel has been 

enabled (e.g. 172.50.22.1).  

4. Enter a value in the field Prefix: The (network) prefix identifies the subnet 

mask used, or the address range for which the address translation is 

done. 

Example: 

Real Address: 172.25.22.0 

Translated Address: 172.22.70.0  

Prefix 24  

This will cause all addresses from 172.25.70.0 to 172.25.70.255 to be 

mapped to the addresses from  172.22.70.0 to 172.22.20.255. These 

systems are thereby accessible from the client . 

Using DNS 

The HOB PPP Tunnel can use its own DNS, in a similar setup to NAT. When the 

tunnel is enabled, then the stated host names are assigned specific  (numerical) 

IP addresses. 

1. Click the DNS tab and then the Add button. The dialog Add a DNS entry 

will open.  

2. Enter in the field DNS Name: a host name that is to be resolved and click 

Add. 

3. The dialog Add an IP address opens. Enter a (numerical) IP address and 

then click Add & Close. 

4. You can enter additional IP addresses. When one is not available the next 

in the list will be used. 

Exclude DNS 

If certain host names should not be resolved by the H OB WebSecureProxy once 

the PPP Tunnel is enabled, then enter these in the tab Exclude DNS. These 

addresses will then be resolved by the  DNS server in the L2TP server network.  

 

Make sure to enter the host name of the system on which the  HOB 

WebSecureProxy is installed. This ensures that connections will not be 

encrypted twice  (double SSL).  

1. Click the Exclude DNS tab and then the Add button. The dialog Add an 

excluded DNS name will open.  

2. Enter a host name and click Add and close to apply the changes . 
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4.1.4.  Configuration  of the  L2TP Server  

For this section the Microsoft RAS Server  is used as an illustrating example. The 

HOB PPP Tunnel uses SSL encryption, so the Microsoft RAS Server Security 

Policy is no longer needed. On the Microsoft Support  site you can find an article 

with instructions on how to deactivate the  L2TP/IPSec policy. Please note: This 

article refers to Windows 2000 Server, yet it is also relevant for later Microsoft 

Windows Server versions. You can find this information at the following link :  

http://support.microsoft.com/kb/310109/en -us 

 

After deactivating the L2TP/IPSec Policy, you should use this RAS 

server exclusively for connections over the HOB PPP Tunnel, as 

otherwise no encrypt ion of the connections will take place.  

L2TP Server Authentication 

Authentication for connections going over the HOB PPP Tunnel is done in the 

WebSecureProxy. Optionally, depending on the setting of the L2TP server, 

additional authentication can take plac e on the L2TP server. 

This allows you to restrict the number of people who can use the HOB PPP 

Tunnel.  

For User/Password authentication on the L2TP server the same User/Password 

data as in the WebSecureProxy can be set.  

When the authentication on the WebSecureProxy is done with tokens or client -

side SSL, then authentication on the L2TP server is not possible. In this case, the 

L2TP server should be so set that guest authentication is possible.  

Another authentication possibility is that of using a S hared Secret. To do this, the 

L2TP server is to be configured that the shared secret conforms to that of the  

HOB EA Server. The IP address and port (default 13273) of the EA Server must 

also be entered. 

 

To configure the shared secret in the EA Server, start EA Administration and 

select EA Server > Configure > HOB WebSecureProxy tab. 

Using a shared secret gives the advantage of also making it possible to use 

tokens or client -side certificates.  

 

 

 

http://support.microsoft.com/kb/310109/en-us
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4.1.5.  Configuration of the User Start Page  

To have a hyperlink for starting the HOB PPP Tunnel displayed on the HOB RD 

VPN login/initial page, proceed as follows:   

1. Start HOB EA Administration and log in.  

2. Right click the database element (user or user group) the configuration of 

which is to be edited and select Configure > HOB RD VPN > User 

Settings. The HOB RD VPN configuration program will open.  

 

 
 

3. In the tree structure at the left, select the entry Properties and select the 

database element to be configured (e.g. guest,users,firm).  

4. Change the entry in the field Initial page to: 
/home/welcomeGate.html  

5. Click Close for the changes to be accepted.  

6. With the next login the initial page (the HOB Welcome Gate) will now have 

a link in the Connectivity panel to start the PPP Tunnel (see 6.2 Using the 

HOB Web Server Gate, page 66). 
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4.1.6.  System configuration for LINUX, Unix and Mac 

operating systems  

The HOB PPP Tunnel on the LINUX, Unix and Mac operating systems uses the 

system application PPP Daemon (pppd). As further configuration must be done 

in order for the HOB PPP Tunnel to run successfully, HOB RD VPN provides a 

setup utility to automatically do this.  

When the PPP Tunnel is started for the first time a dialog informs th e user of the 

need for further configuration and directs the browser to a page from where the 

setup utility can be downloaded.  

 

This configuration setup utility must be run with full administrator 

rights. 

This setup utility performs the following steps:  

1. Checks for administrator credentials  

2. Sets the Restricted Deletion Flag (sticky bit) of the PPP Daemon. The 

command for this is: chmod u+s /usr/bin/pppd  

3. Creates the following files if they do not yet exist:  

¶ /etc/ppp/options  

¶ /etc/ppp/ip - up 

¶ /etc/ppp/ip - down 

¶ / etc/ppp/peers/hobppptunnel  

4. Appends a script to the files:  

¶ /etc/ppp/ip - up 

¶ /etc/ppp/ip - down 
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4.2. Using the HOB PPP Tunnel  

Now that it has been installed and configured, the HOB PPP Tunnel  is ready for 

use. 

1. Open the HOB RD VPN Start page (the HOB Welcome Gate) 

2. Click the link Start PPP Tunnel 

The PPP Tunnel will be established automatically. A tray icon appears and a 

connection to your company network is established. Click on the tray icon to 

open a status dialog of the PPP Tunnel, and which you can use to terminate the 

connection.  

 

If the PPP Tunnel cannot be established, to diagnose the problem and 

help to fix it, please see the following tools and files:  

¶ For Windows: the Event log 

¶ For LINUX/Unix: /var/log/message  

¶ For Mac: the Console 
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5. HOB Web File Access  

HOB Web File Access is a component of HOB RD VPN that allows users to 

access files on servers within the enterprise network over the Internet. This 

access is controlled with a browser, w ith the file system displayed  in a tree 

structure similar to that of Windows Explorer. 

HOB Web File Access is a HOB EA Server PlugIn and can be deactivated if it is 

not needed.  

5.1. Web File Access - Configuration  

The following settings must be made in order to use Web File Access:  

5.1.1. Activa ting the Web File Access PlugIn  

After installing HOB RD VPN, the HOB Web File Access PlugIn is activated as 

default. If it has been deactivated, you can reactivate it as follows:  

1. Start HOB EA Administration and log in.  

2. Select the menu item EA Server > Configure 

3. Select the Server PlugIn tab 

4. Activate the option in the Start Server PlugIn column. 

 
In the Parameter column you can enter start parameters .  

 

Further information on this subject can be found in the online help.  
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Web File Access PlugIn: Parameters 

port= 

The IP port at which the Web File Access Web server listens for incoming 

connections  This parameter is optional. The default port is 8080. 

bind=all 

This parameter makes it possible for connections from the b rowser to go directly 

to the Web File Access Web server. If this parameter is not set , connections can 

only be made over HOB RD VPN.  

5.1.2. Configuring HOB RD VPN User Settings  

In the next step you will make a configuration for  Web File Access, which is 

assigned to a database element (User, Group or Firm). Proceed as follows: 

1. Start HOB EA Administration and log in. 

2. Right click the database element for which you want to make a configuration 

and select Configure > HOB RD VPN > User settings. 

The HOB RD VPN configuration program will open . 

3. On the left of the tree structure, select the scheme  Web File Access. 

4. Click the Add button . 

 

 

 

5. Enter the data for Domain, Login, etc.  

6. Click the Add Server button and create a list of servers that the user can 

access with Web File Access. 

  

The settings that you make here will be inherited by the lower level database 

elements, if they have no such configuration of their own . For example, the 

element user1,users,firm will inherit the settings from  users,firm. 
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Access rights to the server are regulated by the operating sys tem of 

the corresponding server, i n that you will need a server entry in HOB 

RD VPN as well as access rights to the corresponding s erver. 

 

 

To enhance the performance of Web File Access, you should use the 

Bypass Feature from Web Server Gate for the Web File Access Server. 

This is the default setting and should be retained.  

5.2. Working with Web File Access  

The user starts Web File Access by clicking the link Web File Access on the HOB 

RD VPN starting page. If authentication has been set, a login window in wh ich to 

enter authentication data will open .  

After a successful authentication (if required) the Web File Access window will 

open. On the left there will be an Explorer-like tree structure displaying the 

servers and directories. To the right you will see the folders and files. 

To access the files, first select the desired server and directory from the tree 

structure, and to edit an item, right -click it or click one of the symbols above the 

list. Using the symbols above the list you can create new folders an d upload files 

to the remote server.  

Using the right mouse button, you can : 

¶ Rename files 

¶ Download files 

¶ Download several files/folders as a Zip -archive 

¶ Delete files/folders 
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6.  Access to Enterprise -Internal Web Servers  ® HOB 

Web Server Gate   

Usually, enterprise-internal Web servers that are protected by  a firewall cannot 

be accessed over the Internet. To overcome this HOB RD VPN supports SSL-

secured access to enterprise -internal servers over the HOB RD VPN Web Server 

Gate. The "secure" access is implemented taking the following criteria  into 

account : 

Confidentiality  - The data cannot be read by unauthorized persons.  

Integrity - The data are protected from being manipulated by unauthorized 

persons. 

Authenticity  - Before the data are exchanged, each participant has to prove their 

identity during logon. Access will be denied those who are unauthorized. 

6.1. HOB RD VPN Web Server Gate   

The scenario below shows a connection to an internal Web server using the HOB 

RD VPN Web Server Gate. All browser connections are routed over the Web 

Server Gate and then relayed by this to the Web server . 

 

 

 

 

As all browser connections are rerouted through the Web Server Gate 

and therefore are not directly accessed from their server of origin, thus 

violating a fundamental browser security policy , the Same Origin 

Policy. In the event that one malicious server manages to establish 

contact with the Web Server Gate then this server could affect the 

integrity of the Web Server Gate and other trusted servers with whom 

the Web Server Gate is in contact. 

With this in mind, HOB strongly recommends the following steps are 

implemented to resist this:  














































































































































































